Top up transactions are unavailable

Incident Report for Snappi

Resolved

All services are fully restored. The issue has been resolved — enjoy your full Snappi experience!
Posted Jun 25, 2026 - 14:55 EEST

Monitoring

The issue has been fixed and we’re monitoring the service to ensure everything is stable.
Posted Jun 25, 2026 - 14:31 EEST

Identified

We’ve identified the cause of the issue and are working to resolve it as quickly as possible.
Posted Jun 25, 2026 - 13:47 EEST
This incident affected: Transactions (Top Up).