Snappi App is currently experiencing issues

Incident Report for Snappi

Postmortem

On October 29, 2025, Snappi services were impacted by an outage from a third-party provider, Azure Cloud. While we have since resolved the immediate impact on our services, our teams are continuing to work on a full Post-Incident Review.

Microsoft has published its summary of the event, which you can find here: Azure Incident Summary.

We are continuing our own thorough internal investigation to understand the full impact and to identify corrective actions to help prevent similar occurrences in the future.

We sincerely apologize for the disruption this incident caused you and appreciate your patience during this incident.

Posted Oct 30, 2025 - 06:20 EET

Resolved

Our team is now able to see full recovery across all of our services.

We apologise for the inconvenience that this incident has caused and we will provide further information when the Post Incident Investigation has been completed.
Posted Oct 30, 2025 - 06:14 EET

Update

Our teams are continuing to monitor the recovery of systems.
Posted Oct 29, 2025 - 21:58 EET

Monitoring

We've started seeing continued experience improvement.

While our public cloud provider is still working on mitigating this issue, we are seeing improvements in the systems operational capabilities in our App. We estimate a significant improvement within the next few hours and will continue to monitor the health of Azure services and the effects on Snappi customers. We appreciate your continued patience and remain committed to full resolution as we work through this situation. We will post our next update soon.
Posted Oct 29, 2025 - 21:22 EET

Update

Thank you for your continued patience. We understand the impact this issue is having on you and want to assure you that resolving this matter is our highest priority. Our public cloud provider is still actively working to mitigate this issue with urgency and while we do not have a definitive ETA at this time, we remain committed to full resolution and deeply appreciate your patience as we work through this situation. We will be providing hourly updates on this issue.
Posted Oct 29, 2025 - 21:02 EET

Update

Our public cloud provider is working to mitigate this issue quickly. We are seeing some early positive indicators and are continuing to monitor. We appreciate your patience and will continue to provide updates every hour or sooner.
Posted Oct 29, 2025 - 20:13 EET

Update

Our public cloud provider is working to mitigate this issue quickly. We appreciate your patience and will continue to provide updates every hour or sooner.
Posted Oct 29, 2025 - 19:36 EET

Update

We are experiencing an outage due to some issue at the end of our public cloud provider. We are working closely with them to get this resolved or mitigated as quickly as possible. ETA of the same is not known at the moment.
We shall continue to share updates every hour, if not sooner.
Posted Oct 29, 2025 - 19:08 EET

Identified

We’ve identified the cause of the issue and are working to resolve it as quickly as possible.

Έχουμε εντοπίσει την αιτία του προβλήματος και εργαζόμαστε για την άμεση επίλυσή του.
Posted Oct 29, 2025 - 18:39 EET

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 18:31 EET

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 18:30 EET

Investigating

We’re currently experiencing a service disturbance. Our team is actively investigating the root cause and will update you as soon as possible.

Αυτή τη στιγμή αντιμετωπίζουμε μια διαταραχή στην υπηρεσία. Η ομάδα μας διερευνά την αιτία και θα σας ενημερώσουμε το συντομότερο δυνατό.
Posted Oct 29, 2025 - 18:12 EET
This incident affected: Mobile App, Onboarding, Top Up, Card Payments, Ecommerce Payments, Transfers, IRIS, BNPL, and Website.