Snappi App experiencing issues

Incident Report for Snappi

Resolved

All services are fully restored. The issue has been resolved — enjoy your full Snappi experience!
Posted Nov 25, 2025 - 14:31 EET

Monitoring

The issue has been fixed and we’re monitoring the service to ensure everything is stable.
Posted Nov 25, 2025 - 14:03 EET

Identified

We’ve identified the cause of the issue and are working to resolve it as quickly as possible.
Posted Nov 25, 2025 - 13:06 EET

Update

We're continuously investigating this issue. While we have not identified the root cause of the issue yet it seems that all Snappi services as well as the Mobile App is not affected.

An error appears to all customers as soon as they log in to the Snappi App. Pressing "OK" to that error message will allow you to use the Snappi App as usual.

We will provide updates regarding this issue regularly. Thank you for your patience and understanding.
Posted Nov 25, 2025 - 12:47 EET

Investigating

We’re currently experiencing a service disturbance preventing users from logging in or using our services. Our team is actively investigating the root cause and will update you as soon as possible.
Posted Nov 25, 2025 - 12:19 EET
This incident affected: Mobile App.