Issues with the Digital Onboarding

Incident Report for Snappi

Resolved

All services are fully restored. The issue has been resolved — enjoy your full Snappi experience!
Posted Dec 04, 2025 - 20:19 EET

Monitoring

The issue has been fixed and we’re monitoring the service to ensure everything is stable.
Posted Dec 04, 2025 - 20:16 EET

Identified

We’ve identified the cause of the issue and are working to resolve it as quickly as possible.
Posted Dec 04, 2025 - 19:27 EET

Investigating

We’re currently experiencing a service disturbance. Our team is actively investigating the root cause and will update you as soon as possible.
Posted Dec 04, 2025 - 18:40 EET
This incident affected: Onboarding.