Cash Now is unavailable

Incident Report for Snappi

Resolved

All services are fully restored. The issue has been resolved — enjoy your full Snappi experience!
Posted Feb 28, 2026 - 22:12 EET

Identified

We’ve identified the cause of the issue and are working to resolve it as quickly as possible.
Posted Feb 28, 2026 - 19:01 EET
This incident affected: Loans (Cash Now).