Τhe technical issue that was temporarily affecting new sign-ups has now been resolved. It was due to an external system we connect with but everything is now fully restored and running smoothly.
You can jump right back in and complete your Snappi onboarding in just a few minutes.
Thanks again for your patience and for joining us on the “banking the way you want to live” journey with Greece’s first ECB-licensed neobank.
Posted Nov 14, 2025 - 12:18 EET
Monitoring
The onboarding journey should now be working as expected. We will continue to monitor its behaviour for the following hours. You can now onboard to Snappi! Thank you for your patience.
Posted Nov 14, 2025 - 11:36 EET
Update
We are working on a workaround until our vendor provides a permanent fix. We will keep you updated. Thank you for your patience and understanding.
Posted Nov 14, 2025 - 09:23 EET
Update
Our vendor identified the root cause of the issue and working to fix it. We will keep you updated on the progress. Thank you for your patience and understanding.
Posted Nov 13, 2025 - 15:42 EET
Update
We are continiously working on resolving this issue. We will keep you updated with regular updates. Thank you for your patience and understanding.
Posted Nov 13, 2025 - 09:45 EET
Update
We are continiously working on resolving this issue. So far, we've identified that the issue is related to specific information that is not retrieved from the EGov side during the EGov verification step of the Onboarding. This is happening because of an outage on the vendor side. We are working closely with them to resolve the issue.
Posted Nov 13, 2025 - 07:18 EET
Identified
We’ve identified the cause of the issue and are working we the relevant vendor to resolve it as quickly as possible. We will provide regular updates on the issue here.
Posted Nov 12, 2025 - 20:37 EET
Investigating
We’re currently experiencing issues with EGov Verication during Onboarding. Our team is actively investigating the root cause with the relevant Vendor and will update you as soon as possible.