Issues with EGov Verification During Onboarding

Incident Report for Snappi

Resolved

Τhe technical issue that was temporarily affecting new sign-ups has now been resolved. It was due to an external system we connect with but everything is now fully restored and running smoothly.

You can jump right back in and complete your Snappi onboarding in just a few minutes.

Thanks again for your patience and for joining us on the “banking the way you want to live” journey with Greece’s first ECB-licensed neobank.
Posted Nov 21, 2025 - 12:10 EET

Monitoring

A fix has been implemented from our end to mitigate this issue and allow you to complete your onboarding and enjoy the full Snappi Experience.

We will continue to monitor this situation until is fully resolved and will keep you informed with regular updates.

Thank you for your patience.
Posted Nov 21, 2025 - 10:45 EET

Identified

Starting approximately on the 20th of November at 9:30 pm we are facing some issues with Egov Verification during onboarding.
There is an issue with the Ministry of Labour services. Our Vendor has been informed and working on the resolution of the issue. We will keep you updated with regular updates.

Thank you for your patience and understanding.
Posted Nov 21, 2025 - 08:18 EET
This incident affected: Onboarding.