Investigating an issue with To Up

Incident Report for Snappi

Resolved

All services are fully restored. The issue has been resolved — enjoy your full Snappi experience!
Posted Jun 27, 2026 - 01:50 EEST

Identified

We’ve identified the cause of the issue and are working to resolve it as quickly as possible.
Posted Jun 27, 2026 - 00:16 EEST

Investigating

We’re currently experiencing an issue with Top Up being unavailable. Our team is actively investigating the root cause and will update you as soon as possible.
Posted Jun 26, 2026 - 23:13 EEST
This incident affected: Transactions (Top Up).