Transactions are getting declined

Incident Report for Snappi

Resolved

All services are fully restored. The issue has been resolved — enjoy your full Snappi experience!
Posted Dec 04, 2025 - 15:47 EET

Update

We are continuing to monitor for any further issues.
Posted Dec 04, 2025 - 14:55 EET

Monitoring

The issue has been fixed and we’re monitoring the service to ensure everything is stable.
Posted Dec 04, 2025 - 14:54 EET

Identified

We’ve identified the cause of the issue and are working to resolve it as quickly as possible.
Posted Dec 04, 2025 - 14:46 EET

Investigating

We’re currently experiencing an issue with some transactions getting declined. Our team is actively investigating the root cause and will update you as soon as possible.
Posted Dec 04, 2025 - 14:38 EET
This incident affected: Card Payments and IRIS.