Cash Now can't be finilized

Incident Report for Snappi

Resolved

All services are fully restored. The issue has been resolved — enjoy your full Snappi experience!

Όλες οι υπηρεσίες έχουν αποκατασταθεί πλήρως. Το πρόβλημα επιλύθηκε — μπορείτε να απολαύσετε την πλήρη εμπειρία της Snappi!
Posted Mar 06, 2026 - 18:48 EET

Identified

We’ve identified the cause of the issue and are working to resolve it as quickly as possible.
Posted Mar 06, 2026 - 18:39 EET

Investigating

We’re currently experiencing a service disturbance affecting Cash Now Loans. Our team is actively investigating the root cause and will update you as soon as possible.
Posted Mar 06, 2026 - 18:19 EET
This incident affected: Loans (Cash Now).